FormZ lights and Maxwell Register | Edit Profile | Moderators | Log Out
Topics | Last Day | Last Week | Search

AutoDesSys Forums » form•Z Discussion » Archive 2007 » Archive February 2007 » FormZ lights and Maxwell « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

John Odom
Junior Member
Username: Jodom

Post Number: 45
Registered: 10-2006
Posted on Friday, February 02, 2007 - 12:34 am:   Edit Post Print Post

So I realize this isn't the place for Maxwell discussion, but they have made that plug-in so closely knit to FormZ they almost stream together, it is so nice! I just had one question, and I hope someone can answer it for me. I added some fmz lights into an interior scene and then tried to render it with Maxwell, but I got nothing but a black box, is there a simple setting you have to use to get Maxwell to understand a fmz light, or is there specific Maxwell lights I have to use.

Thanks

John
Top of pagePrevious messageNext messageBottom of page Link to this message

chris lawes
New member
Username: Chrislawes

Post Number: 20
Registered: 02-2002
Posted on Friday, February 02, 2007 - 07:28 am:   Edit Post Print Post

for interior lights you will have to create an object for the bulbs with maxwell emitter materials applied

Ive been trying it out this morning seems to work very well
Top of pagePrevious messageNext messageBottom of page Link to this message

Jean-Luc DAUREIL
Intermediate Member
Username: Jean_luc

Post Number: 92
Registered: 07-2001


Posted on Friday, February 02, 2007 - 08:56 am:   Edit Post Print Post

John,

In addition to Chris's words,I've read in the last plugin manuel that an emmitter doesn't support several materials applied on it.
You may verify if only one emmitter material is applied on it.

This said i've tried to reproduce this.
It seem that MaxwellZ apply a physical sky even if the option is unchecked in the appropriate case of the menu. Note that the sun is correctly disable.

So in this case if your light's intensity is lower than the atmospheric light you should don't see his effect.

Just try to set the hour to 2 (night) an render.
If you see a black rendering, increase the intesity of the material light.

At the end if you don't want to see the object, go to maxwell parameter for the specific object and check "hide to camera".

In conclusion i'think this work fine except the sky option...

Perhaps somebody have an idea on this point...
In fact we can see as normal because in real life we cannot turn off the sun :-)

Jean-Luc

(Message edited by Jean_Luc on February 02, 2007)
Top of pagePrevious messageNext messageBottom of page Link to this message

John Odom
Junior Member
Username: Jodom

Post Number: 47
Registered: 10-2006
Posted on Friday, February 02, 2007 - 09:36 am:   Edit Post Print Post

Ok that makes sense, I remember in the last plugin you could add a attribute to it, being an emitter, and that was how you did it... Makes sense that they would put it into the material pallate. So should I make a light through the material style in Maxwell Studio and then bring it in through the materials pallate in form z? Is that the best way?

Thanks,

John
Top of pagePrevious messageNext messageBottom of page Link to this message

Roman
New member
Username: Teamturbo

Post Number: 12
Registered: 11-2003
Posted on Friday, February 02, 2007 - 09:39 am:   Edit Post Print Post

I remember reading somewhere that we can use the FormZ sun for position. Is that possible? How do you do it?
Top of pagePrevious messageNext messageBottom of page Link to this message

Jean-Luc DAUREIL
Intermediate Member
Username: Jean_luc

Post Number: 95
Registered: 07-2001


Posted on Friday, February 02, 2007 - 09:55 am:   Edit Post Print Post

Roman
Take a look to the new manual...
and go to Maxwell menu...

JL
Top of pagePrevious messageNext messageBottom of page Link to this message

render monkey
New member
Username: Johna

Post Number: 3
Registered: 02-2007
Posted on Friday, February 02, 2007 - 10:07 am:   Edit Post Print Post

It does seem that disabling the physical sky in formZ Maxwell plugin does not seem to actually turn it off. Two ideas, open the mxm in Studio and then disable it. Or, as I am trying now, using the multilight feature to turn it off. If I am going to use emitters anyway, might as well. The Emixer makes a channel for it.
You can specify the Maxwell sun in formZ by specifying the light direction from the sun in the distant light options. I've tried this once, and it seemed a bit off. Can anyone else confirm?

(Message edited by johna on February 02, 2007)
Top of pagePrevious messageNext messageBottom of page Link to this message

Dan Kessler
New member
Username: Dkessler

Post Number: 16
Registered: 06-2001
Posted on Friday, February 02, 2007 - 12:32 pm:   Edit Post Print Post

I can confirm that the sun angles are a bit off. They're really close, but not exactly the same.

Also, I'm wondering if Maxwell recognizes the "angle of site north" feature in formZ. When I'm constructing a model for a site in downtown Denver, true north is 45 degrees. For obvious reasons, I'm not going to model something at a 45 degree angle. The "angle of site north" feature is really nice for this. I can't get Maxwell to recognize this.
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 1491
Registered: 04-2001


Posted on Friday, February 02, 2007 - 12:45 pm:   Edit Post Print Post

Dan,

There is a VERY small difference between Maxwell's light and ours. We have notified Maxwell of this slight issue.

Maxwell does not (currently) recognize the Angle of Site North option. I am not sure if they can, but we have reported this to Maxwell so they can either add this, or document that it does not work.

ZWebTech Support
Top of pagePrevious messageNext messageBottom of page Link to this message

Dan Kessler
New member
Username: Dkessler

Post Number: 19
Registered: 06-2001
Posted on Friday, February 02, 2007 - 01:09 pm:   Edit Post Print Post

Yes, like I said, they're really close. Here's a comparison. The last image is a combination of the two:

formZ

maxwell

both
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 1494
Registered: 04-2001


Posted on Friday, February 02, 2007 - 02:11 pm:   Edit Post Print Post

Dan,

Interesting, your shadow appears to be off more than ours was in our test. Perhaps it has something to do with the location, or time of day. Anyway, I'm sure that Next Limit can sort this out.

Also, looking at your 3 images, I like the combined one the best. It adds the bumps for the cube in a nice, subtle way, and dissipates much of the Maxwell graininess. :-)

ZWebTech Support
Top of pagePrevious messageNext messageBottom of page Link to this message

Jean-Luc DAUREIL
Intermediate Member
Username: Jean_luc

Post Number: 97
Registered: 07-2001


Posted on Friday, February 02, 2007 - 03:28 pm:   Edit Post Print Post

Yeap Dan,

It seems you've found an interrsting way to use Maxwell!
As Zwebtech said the grain is very reduced but all the shader's effect from Renderzone are preserved.

Can you share your photoshop process?

Jena-Luc

(Message edited by Jean_Luc on February 02, 2007)
Top of pagePrevious messageNext messageBottom of page Link to this message

Dan Kessler
New member
Username: Dkessler

Post Number: 22
Registered: 06-2001
Posted on Friday, February 02, 2007 - 03:36 pm:   Edit Post Print Post

Sure. All I did was copy and paste the maxwell image into the formZ image. As you know, this creates a new layer in Photoshop. Then I set the layer transparency of the maxwell image (on top) to 65%.

Before I settled on this technique, I looked at different blending modes for the maxwell layer (i.e. overlay, multiply, etc.). Simply using layer transparency best showed the difference between shadows.
Top of pagePrevious messageNext messageBottom of page Link to this message

Jean-Luc DAUREIL
Intermediate Member
Username: Jean_luc

Post Number: 98
Registered: 07-2001


Posted on Saturday, February 03, 2007 - 03:34 am:   Edit Post Print Post

Thanks, Dan
Sometimes simpler solutions are best.
You've opened new perpectives...:-)
JL