Enclosure tool Register | Edit Profile | Moderators | Log Out
Topics | Last Day | Last Week | Search

AutoDesSys Forums » form•Z Discussion » Archive 2007 » Archive February 2007 » Enclosure tool « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

m_s
Senior Member
Username: Maher

Post Number: 200
Registered: 08-2006


Posted on Friday, February 23, 2007 - 10:48 am:   Edit Post Print Post

Z,
I was trying last night the derive-3d enclosure tool on non-planer curved geometry. It did not accept it. I had to turn them into facetted wires. Is there a reason this does not work? The file I have is more than 512kb and it kept bouncing back from your email.(I kept .safe) as an extension. Any ideas?

Best,
maher
Top of pagePrevious messageNext messageBottom of page Link to this message

Silicon
New member
Username: Treebeard

Post Number: 18
Registered: 10-2006
Posted on Friday, February 23, 2007 - 11:28 am:   Edit Post Print Post

Maher,

You have to be careful with extensions in OS X, when 'show all file extensions' is turned off from the finder preferences. You can delete and retype the extension, but what really happens is OS X re-adds the previous extension to the end of whatever you typed in. Get Info on the file and look under the 'Name & Extension' field to see what it really there (If you change the extension here it sticks for real). You'll probably see '.safe.zip' instead of the '.safe' that OS X will show you on the desktop.

This is usually the cause of bounced email's from ads' mail server.

This is terrible, 'worst of of both worlds' behavior in my opinion. Similar to Apple's misguided hybridization of the spatial OS 9 Finder and the NeXt browser to 'please both camps'. Instead the OS 9 spatial mode is impossible to use, because it doesn't 'stick' reliably, so everyone gives up and sticks to browser mode.

In a similar vein most people leave the extensions turned on in the Finder to avoid this pitfall

Silicon

(Message edited by treebeard on February 23, 2007)

(Message edited by treebeard on February 23, 2007)
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 1637
Registered: 04-2001


Posted on Friday, February 23, 2007 - 11:55 am:   Edit Post Print Post

Maher

This is a limitation of the smooth modeling algorithm. If you attempt a 2D enclosure on the smooth curve formZ will tell you this directly. The 3d enclosure should do this as well, instead of giving you the generic 'Unable to complete the smooth modeling operation' message.

Thank you for bringing this to our attention, we will update this error message to make it more informative.

The facetted version works because formz is able to examine the plane of each individual segment to derive the direction to perform the offset.

ZWebTech Support
Top of pagePrevious messageNext messageBottom of page Link to this message

m_s
Senior Member
Username: Maher

Post Number: 201
Registered: 08-2006


Posted on Friday, February 23, 2007 - 12:11 pm:   Edit Post Print Post

now it makes sense.. Thanks Silicon.
Z,
Thanks, that explains why..
is there a way or a workaround to turn the generated facetted geometry to smooth?

Thanks
-m
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 1639
Registered: 04-2001


Posted on Friday, February 23, 2007 - 12:46 pm:   Edit Post Print Post

Maher,

Try going back to the original smooth 2D curve, then extrude it out. Then use the Parallel tool with the Double Parallel option (and with or without the On Same Plane option) to get a solid with the thickness you originally desired to get from the 3d enclosure.

Does this do what you want?

ZWebTech Support
Top of pagePrevious messageNext messageBottom of page Link to this message

m_s
Senior Member
Username: Maher

Post Number: 202
Registered: 08-2006


Posted on Friday, February 23, 2007 - 02:26 pm:   Edit Post Print Post

Yup!
Thanks