Splines Joining Register | Edit Profile | Moderators | Log Out
Topics | Last Day | Last Week | Search

AutoDesSys Forums » form•Z Discussion » Archive 2012 » Archive July - Dec 2012 » Splines Joining « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Douglas McLean
Advanced Member
Username: Dmclean

Post Number: 127
Registered: 03-2010
Posted on Tuesday, September 18, 2012 - 06:17 pm:   Edit Post Print Post

How do I prevent my splines from joining together into a closed shape when I don't want them to? I am drawing some point splines with the points placed fairly close together. First two points go okay, but when i click on the third point the shape closes into a surface. There must be a tolerance setting somewhere that I need to fix, but I can't figure out where.

Thanks,

Douglas
Top of pagePrevious messageNext messageBottom of page Link to this message

Ray A
New member
Username: Reflex

Post Number: 23
Registered: 08-2012
Posted on Wednesday, September 19, 2012 - 03:17 am:   Edit Post Print Post

Hi Douglas. I've thought the same thing, but then found I didn't really need the feature.

What's the goal you have? If you don't want a surface, you can use the uncover tool to remove it. If it is because you don't want curve smoothing at the start / end point (as was the case with me) you could use a Bezier curve and adjust the tangents independently.
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 17629
Registered: 04-2001


Posted on Wednesday, September 19, 2012 - 08:36 am:   Edit Post Print Post

Douglas,

If you are within 10 pixels of the start point, then formZ will assume that you want to close the shape. If you zoom in a little closer, does this allow you to draw the desired shape?
Top of pagePrevious messageNext messageBottom of page Link to this message

Douglas McLean
Advanced Member
Username: Dmclean

Post Number: 128
Registered: 03-2010
Posted on Wednesday, September 19, 2012 - 10:15 am:   Edit Post Print Post

Today for some reason known only to the binary gods there is no problem with the file and I am able to draw the spline. Yesterday it was closing on the third point, which was close, but definitely not within the 10 pixel limit. the drawing was quite large and I was working on a ver small area, but it was filling most of the screen, so the pixel limit was not coming into play.

Today all is well.

Thanks,

Doug
Top of pagePrevious messageNext messageBottom of page Link to this message

Douglas McLean
Advanced Member
Username: Dmclean

Post Number: 129
Registered: 03-2010
Posted on Wednesday, September 19, 2012 - 02:59 pm:   Edit Post Print Post

Looking a little further into it, it seems related to the size of the overall model and the view that I am in. If I am in 3D view and pulled back looking at the model, and have hit view all, then track in close to a very small item (I use a 3D Connexions to navigate) and work the spline snaps closed. If I isolate the piece (Shift CMD I) and use view all to zoom in on the piece, the spline does not snap shut. and I can work on points that are quite close together.

Co-incidentally, if I am back far, the grid will not allow me to create a small size grid. If I track in it will still not allow it, but if I have selected the item and done a view all then the grid will allow me to create a small size grid.

My guess is that it has something to do with the tracking in close rather than "zooming" into the item.

Doug
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 17655
Registered: 04-2001


Posted on Wednesday, September 19, 2012 - 03:40 pm:   Edit Post Print Post

Doug,

We tried t reproduce what you describe, but so far this is working for us. Can you send us a little file where the spline drawing and grid setting works as you describe so we can test it here?
Top of pagePrevious messageNext messageBottom of page Link to this message

Douglas McLean
Advanced Member
Username: Dmclean

Post Number: 130
Registered: 03-2010
Posted on Monday, September 24, 2012 - 01:25 pm:   Edit Post Print Post

Sorry to take so long to get this, but the project itself was keeping me pretty busy. Attached is a file that I can consistently get to exhibit the following behaviour.

No objects selected, hit Zoom ALL to see everything in the view.

Use 3D Connexion Navigator to move in extremely close to the cornices shape.

Try to trace one of the curves with Point Spline, set to Snap to Line.

Spline Snaps Closed at third PointSelection.

If I Zoom ALL, then Select the Cornice piece and hit Zoom All again, which then zooms close to the cornice, I can trace the line without the Spline Snapping closed.

I have not been able to recreate the Grid Line Problem again.

If it is of any significance I am also using a Intuos 3 tablet rather than a mouse .

Curious to see if you can reproduce this.

Douglas
application/zip
Spline Snap Problem.fmz.zip (373.9 k)
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 17712
Registered: 04-2001


Posted on Monday, September 24, 2012 - 01:57 pm:   Edit Post Print Post

Hi Douglas,

We have not been able to reproduce this yet. Can you retry the zooming, trace the shape, and when you get the problem, then save and repost the file?

Also, if you try the drawing with a mouse instead of the tablet, do you still have the issue? (We probably have one of those here somewhere, but I don't have it handy...)