FormZ 7 ready for Mac OS Mavericks? Register | Edit Profile | Moderators | Log Out
Topics | Last Day | Last Week | Search

AutoDesSys Forums » form•Z Discussion » Archive 2013 » Archive Oct - Dec 2013 » FormZ 7 ready for Mac OS Mavericks? « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Burney Poh
New member
Username: Paul_burns

Post Number: 4
Registered: 10-2013
Posted on Tuesday, October 22, 2013 - 08:28 pm:   Edit Post Print Post

I want to confirm is Formz 7 is tested compatible with MacOS 10.9 before upgrading. Anyone have any issue?
Top of pagePrevious messageNext messageBottom of page Link to this message

markus groeteke
Senior Member
Username: 3dworks

Post Number: 628
Registered: 11-2002


Posted on Wednesday, October 23, 2013 - 05:31 am:   Edit Post Print Post

same question...
Top of pagePrevious messageNext messageBottom of page Link to this message

Des Clarke
Senior Member
Username: Desclarke

Post Number: 923
Registered: 11-2001


Posted on Wednesday, October 23, 2013 - 05:35 am:   Edit Post Print Post

I'm going to wait a while... Looks great but it's only been a day
Top of pagePrevious messageNext messageBottom of page Link to this message

markus groeteke
Senior Member
Username: 3dworks

Post Number: 629
Registered: 11-2002


Posted on Wednesday, October 23, 2013 - 07:16 am:   Edit Post Print Post

should bring a lot of benefits with faster open gl and memory compression...
Top of pagePrevious messageNext messageBottom of page Link to this message

Rudy Daverveld
Intermediate Member
Username: Visual_8

Post Number: 82
Registered: 09-2010


Posted on Wednesday, October 23, 2013 - 07:37 am:   Edit Post Print Post

Form Z 6.7 is not liking the update and is no starting up....
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20723
Registered: 04-2001


Posted on Wednesday, October 23, 2013 - 08:38 am:   Edit Post Print Post

Gentlemen,

We have been testing with this and hope to report our findings later today. As with any X.0.0 release of software (especially operating systems), caution is recommended when upgrading, especially including backing up your data and keeping a backup system (dual boot or other) so that you can always revert in case you find an issue that is detrimental to your productivity.

Rudy,

If you are having issues, we would recommend deleting reinstalling the software if you have not done so already. And of course you will need to reinstall the WIBU Driver for versions of formZ prior to v7 if you upgrade your system.
Top of pagePrevious messageNext messageBottom of page Link to this message

Kevin M
Advanced Member
Username: Kevin_m

Post Number: 120
Registered: 06-2009
Posted on Wednesday, October 23, 2013 - 09:12 am:   Edit Post Print Post

I haven't used v7 with Mavericks that much yet but can report that it opens fine and I haven't experienced any issues in my limited time with it so far.

(Message edited by Kevin_M on October 23, 2013)
Top of pagePrevious messageNext messageBottom of page Link to this message

Rudy Daverveld
Intermediate Member
Username: Visual_8

Post Number: 83
Registered: 09-2010


Posted on Wednesday, October 23, 2013 - 09:47 am:   Edit Post Print Post

Ok I'm Trying that, but the installer crashes on start up, is this something we can solve?

Rudy
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20724
Registered: 04-2001


Posted on Wednesday, October 23, 2013 - 10:16 am:   Edit Post Print Post

Rudy,

Please send an email to support@formz.com with complete details of which installer you are running, and include the crash log so we can help...
Top of pagePrevious messageNext messageBottom of page Link to this message

K.S.
Senior Member
Username: Kim

Post Number: 683
Registered: 02-2002
Posted on Wednesday, October 23, 2013 - 11:02 am:   Edit Post Print Post

Testing on Maverick;

layout mode when saving I get the following error message:

Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20725
Registered: 04-2001


Posted on Wednesday, October 23, 2013 - 11:08 am:   Edit Post Print Post

Hi Kim,

That is likely a Permissions Error or a bad character in the path. Please make sure that you don't have any "illegal characters" like : or / or * -- and if that's not it, Set Read / Write Permissions to the folder(s) to which you wish to save, Apply to the Enclosed items, run Disk Utility, and Repair Disk Permissions.

Does that fix it for you?
Top of pagePrevious messageNext messageBottom of page Link to this message

K.S.
Senior Member
Username: Kim

Post Number: 684
Registered: 02-2002
Posted on Wednesday, October 23, 2013 - 11:11 am:   Edit Post Print Post

False alarm: User error


So far all is good except that the FZ logo now appears in lieu of Folder icons in a few spots? Free marketing for FZ?
Top of pagePrevious messageNext messageBottom of page Link to this message

Andrew Birch
Member
Username: Povaratti

Post Number: 74
Registered: 12-2007
Posted on Wednesday, October 23, 2013 - 01:27 pm:   Edit Post Print Post

I would be extremely disrupted if v6.7 doesn't work in Mavericks.
Please keep us updated on what we can expect here, zWeb.
Top of pagePrevious messageNext messageBottom of page Link to this message

Des Clarke
Senior Member
Username: Desclarke

Post Number: 924
Registered: 11-2001


Posted on Wednesday, October 23, 2013 - 01:57 pm:   Edit Post Print Post

Yep, that's why I'm going to wait a bit more. Even though I'm using v7.3 most of the time now, I still want v6.7 to be running for some stuff....

Des
Top of pagePrevious messageNext messageBottom of page Link to this message

Robert Woodruff
Senior Member
Username: Setz

Post Number: 854
Registered: 09-2006
Posted on Wednesday, October 23, 2013 - 02:30 pm:   Edit Post Print Post

Yes, VERY important for V6 to run on Maverics.
Top of pagePrevious messageNext messageBottom of page Link to this message

K.S.
Senior Member
Username: Kim

Post Number: 687
Registered: 02-2002
Posted on Wednesday, October 23, 2013 - 02:45 pm:   Edit Post Print Post

No problem running V6 on OS 10.9 using MBP retina.

Did a quick reopening of an existing modeling and draft file, to reference some material.

All worked okay.
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20735
Registered: 04-2001


Posted on Wednesday, October 23, 2013 - 04:11 pm:   Edit Post Print Post

Ladies & Gentlemen,

We have been testing formZ and bonzai3d with OS X 10.9 for awhile now and we have verified that formZ 7.3, bonzai3d 3.2, and formZ 6.7.3 are launching properly and appear to be running without issues. NOTE that this is not a certification for these systems yet, as we have not yet tested every display or export mode with every possible piece of geometry, but so far things appear to be working properly. Also note that versions of formZ prior to 6.7.3 will NOT install on OS X 10.9 and will not be certified for use there (although it is possible that they can be made to run with 10.9).

If you wish to be one of the early adopters and try this system now, feel free to do so, but we would recommend that you keep a back-up system just in case you do encounter any issues. (And of course back up your data before applying the update to the system.)

If you do find any issues with formZ and OS X 10.9, please let us know and we will look into it ASAP. But again, so far things appear to be working properly. We will continue testing over the next couple weeks, and if no major issues are found, then we will add this to our list of approved systems (and if issues are found, we will take action as necessary).
Top of pagePrevious messageNext messageBottom of page Link to this message

Andrew Birch
Member
Username: Povaratti

Post Number: 75
Registered: 12-2007
Posted on Wednesday, October 23, 2013 - 06:55 pm:   Edit Post Print Post

thanks Éthats great to hear. I'll wait for the point release, myself.
Top of pagePrevious messageNext messageBottom of page Link to this message

robert smith
Senior Member
Username: Bob

Post Number: 1110
Registered: 03-2002


Posted on Wednesday, October 23, 2013 - 08:39 pm:   Edit Post Print Post

huh?


quote:

thanks Éthats great to hear. I'll wait for the point release, myself.


Top of pagePrevious messageNext messageBottom of page Link to this message

Dan Shear
Senior Member
Username: Redrngr

Post Number: 775
Registered: 04-2001


Posted on Thursday, October 24, 2013 - 06:58 am:   Edit Post Print Post

Robert,

ADS states 'We have been testing formZ and bonzai3d with OS X 10.9 for awhile now and we have verified that formZ 7.3, bonzai3d 3.2, and formZ 6.7.3 are launching properly and appear to be running without issues. (NOTE that this is not a certification for these systems yet, as we have not yet tested every display or export mode with every possible piece of geometry, but so far things appear to be working properly).'

So, it appears everthing is working properly. Yet, they have Not tested it on every single system. So, waiting for ADS Final Certification on this matter might be a good idea.

Dan S.
Top of pagePrevious messageNext messageBottom of page Link to this message

robert smith
Senior Member
Username: Bob

Post Number: 1111
Registered: 03-2002


Posted on Thursday, October 24, 2013 - 08:07 pm:   Edit Post Print Post

Ok, I installed Mavericks on a test drive and it seems to be working fine for me. Nothing earth shattering, but no issues either so far.

(Just don't do this with your main system unless you have a backup plan!)
Top of pagePrevious messageNext messageBottom of page Link to this message

Carlos Rego
Senior Member
Username: Carlosrego

Post Number: 449
Registered: 01-2003
Posted on Friday, October 25, 2013 - 08:25 am:   Edit Post Print Post

Hi Z,

I just installed a brand new copy of FZ on Mavericks and I cannot open the FZ because it is being classified by the system as an unidentified developer.

Any tip about how can I turn around this issue?

Thank you,

Carlos
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20745
Registered: 04-2001


Posted on Friday, October 25, 2013 - 08:32 am:   Edit Post Print Post

Hi Carlos,

Yes, we update our software frequently and Apple hasn't caught up yet. Just right click on the formZ.app and choose Open. Then you can click Open once more -- and from then on it will launch normally...
Top of pagePrevious messageNext messageBottom of page Link to this message

Carlos Rego
Senior Member
Username: Carlosrego

Post Number: 450
Registered: 01-2003
Posted on Friday, October 25, 2013 - 08:35 am:   Edit Post Print Post

Problem solved... I just had to change my security setting that were configured to only accept applications from app store and Identified developers.

So... you're an unidentified developer... interesting ;)
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20749
Registered: 04-2001


Posted on Friday, October 25, 2013 - 08:37 am:   Edit Post Print Post

Hi Carlos,

Yes, you can also adjust your Security settings -- but using the right click: Open command, you can leave that as is if you want. We are "identified" -- we just need to get Apple to update their records. :-)
Top of pagePrevious messageNext messageBottom of page Link to this message

Justin Montoya
Junior Member
Username: Jymontoya

Post Number: 28
Registered: 05-2010
Posted on Tuesday, October 29, 2013 - 02:39 pm:   Edit Post Print Post

Quote:
K.S. - So far all is good except that the FZ logo now appears in lieu of Folder icons in a few spots? Free marketing for FZ?

I'm also seeing this, anyone else found a fix yet?
Top of pagePrevious messageNext messageBottom of page Link to this message

Des Clarke
Senior Member
Username: Desclarke

Post Number: 926
Registered: 11-2001


Posted on Thursday, October 31, 2013 - 07:11 am:   Edit Post Print Post

I bit the bullet yesterday and upgraded to Mavericks. FormZ is running fine, but just as with Justin, some of my folder icons are using the FormZ icon.... I can just paste an icon to replace it, but still a little wierd....


icon
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20796
Registered: 04-2001


Posted on Thursday, October 31, 2013 - 11:51 am:   Edit Post Print Post

Hi Des and Justin,

Yes, we have verified that this can happen on certain systems. The folder icons are controlled by the system (not us) but it is a little odd. We will investigate this further and see if we can tell why this might occur.

(Or if you research the issue and find the cause (or is this a feature?), please post back here...)
Top of pagePrevious messageNext messageBottom of page Link to this message

support@formZ.com
Moderator
Username: Tech

Post Number: 20801
Registered: 04-2001


Posted on Friday, November 01, 2013 - 02:19 pm:   Edit Post Print Post

Hi Gentlemen,

Regarding the folder icons, we haven't been able to find too much, other than that there are some users having the same issue with out formZ, like this one:

https://discussions.apple.com/message/23535763#23535763

There is a manual way to customize the folder icons as documented here:

http://support.apple.com/kb/PH13922?viewlocale=en_US

And while many people are happy with the upgrade, there are also lots of people griping about issues with Mavericks. Other than the icon issue (which we see on one computer) everything seems to be going well, but I would still recommend upgrading on a secondary system, or dual booting your computer in case you have mission critical issues and you need another option...