form•Z v9 DOCUMENTATION

WHAT IS NEW IN form•Z v9


There are a number of changes in form•Z v9 “under the hood”. While these are not glamorous improvements, they are core changes that improve the form•Z platform and are designed to improve performance, stability and allow future development for years to come.
These improvements include a new memory manager, new ACIS library and new instance engine among many others.

form•Z v9 Platforms supported.

  • Mac OS 10.11 (or later).
  • 64 bit editions of Windows 10, Windows 8 and Windows 7.

form•Z project files

form•Z v9 project files (.fmz, .fml) are not the same format as form•Z v8 files. This format change allowed for some significant improvements:
  • Files sizes > 2Gb!
  • Better performance.
  • Better texture cache (uses less space, faster).
  • Faster auto save.
  • File size optimization improvements.

Saving to a previous version

To save a file created with form•Z v9 to a previous version, please use the “Save a Copy as” feature.

Using V-Ray for form•Z with form•Z v9

` V-Ray for form•Z will work with with form•Z v8.6 or v9, however, you will need to add the path to the form•Z v8 V-Ray for form•Z plugin to form•Z v9 :

  • Open the Extensions Manager (Extensions menu).
  • Select the Search Paths button.
  • Select the + (add) icon.
  • Navigate to the location of form•Z v8 V-Ray for form•Z installation and click Open: “/Applications/formZ 8/Plugins” on MacO or “/Program Files/formZ 8/Plugins” for Windows.
  • Click OK to exit the Search Paths.
  • Select OK again to exit the Extensions Manager.
  • You will be prompted to restart form•Z.

Upgrading from previous versions

` If you have customized the form•Z key shortcuts and favorites menu from v8.x you will need to save them from v8 to use them in v9.

For key shortcuts

  • In v8.x open The Key Shortcuts Manager (from the Edit Menu).
  • Select the Save button to save a key shortcuts file.
  • In v9 open The Key Shortcuts Manager (from the Edit Menu).
  • Select the load button and select the previously saved v8.x shortcuts file.

For favorites menu

  • In v8.x open the Tool Manager (from the Edit Menu).
  • Select the Save button to save a favorites tool file.
  • In v9 open The Tool Manager (from the Edit Menu).
  • Select the load button and select the previously saved v8.x favorites tool file.

Interface

The tool docks have been redesigned using the latest OS interfaces to create a main application window that uses screen space much more efficiently and adjusts dynamically when resized. The dock areas can be resized by dragging the divider between the docks and the contents adjust dynamically in kind.

All of the palettes that display project contents (materials, objects, layers, line weights etc.) are now “combo” palettes. The palettes can be combined to save screen space. When combined a row of icons will be displayed at the top the palette for each of the combined content. Selecting the icon displays the respective content in the palette. By default, the Views, Scenes, Reference Planes. Clipping planes, Selection sets, Line weight and Line Styles are combined into a single palette at the bottom of the right dock.

Command + click-drag (Mac OS) or Ctrl + click-drag (windows) one palette onto another to combine them. The same method can be used on the icon at the top to drag the content to another palette or into free space to make it independent, re-order the icons, or drag a palette back into the icon toolbar.

If the palette stack on the right exceeds the screen size, use the mouse scroll wheel or option + click-drag (Mac OS) or Alt + click-drag (Windows) to scroll.

The detach icon the palette title bar removes it from the dock. The Dock’s can be rearranged by moving them to the opposite side of the screen. In the context menu for a palette you can select options to move a panel Left/Right or Up/Down. For example, you can move the tool dock to the right of the modeling area.

End point and Mid-Point Snaps

The End point and Mid-Point Snaps a back by popular request!

Inspector palette: The properties of a selection are no longer buried in the Tool Options palette, available only when the user activates the Pick tool. Instead, the Selection, Info, Attributes, and Parameters tabs have been moved to the new Inspector palette, making them available at any time for the user! (more coming soon to this palette). You can access the Inspector window from the Palettes menu, just like any other palette. For convince an ‘Inspector’ button in the Tool Options palette will open the inspector as well.

Inspector palette

The properties of a selection are no longer buried in the Tool Options palette, available only when the user activates the Pick tool. Instead, the Selection, Info, Attributes, and Parameters tabs have been moved to the new Inspector palette, making them available at any time for the user! (more coming soon to this palette). You can access the Inspector window from the Palettes menu, just like any other palette. For convince an ‘Inspector’ button in the Tool Options palette will open the inspector as well.

Project Navigator Palette

This palette is found in the top dock and is a quick way to jump between windows without having to use the Window drop-down list of open projects and windows.

Edit Options Palette

This palette allows easy access to some of the commonly used items from the Edit Pull down menu.

Select by Palette

The Select by palette has a larger area for displaying Materials as well as an option to list Materials by name.

Multi view windows

Multi view windows no longer require an extra click to select the active pane (just move the mouse into the window!).

Reference Files

` Reference Files are a major new feature for form•Z v9. Reference Files are simply data from project files displayed inside another project. Reference file data displays in the graphics window of the project and will render, export and can be snapped too, however it cannot be changed (its “read only”). There are a number of different situations were reference files can make your work flow more efficient.
Sometimes a project can be overwhelming with the amount of data it contains, yet much of that data is static and not a part of what you are modeling, but is important to a design. This data can be kept in a reference file so the real project file only contains the relevant data making it faster to work with and save.
Reference files also support collaboration. Many team members can be working on a project together with each focusing on part of the project. Team members can use reference files to see the work of other team members in their own project.
Reference files can also be useful for repetitive design visualization. For example, a collection of buildings like an apartment complex. A modular building is designed in a single project file and then used as a reference file where it is placed multiple times at various locations and orientations to create a complex. When the modular design is updated, then the entire complex reflects the new design.
Reference files are controlled from the group of commands in the File Menu.

Add Reference File

Add Reference File attaches a reference file to the project. You will be prompted to select a FMZ file. Once chosen, the Reference File Parameters dialog gives you the option to adjust the Position, Rotation, and Scale of the placement of the reference data in the project. You can also choose to import the Objects, Lights, Views, or any combination of the three. Click OK to load in the chosen contents of the Reference File!
The same file can be added multiple times with different parameters to create multiple instances of the reference. The reference file will be listed in the Objects palette. Here you can control the display of the reference file contents (i.e. hide or show).

Create Reference File

Create Reference File creates a new reference file (.fmz) from whatever is selected in your project. This file is then attached as reference file and the original content is removed from the project. This makes it easy to move the cumbersome static data from your project file and relocate it to a reference file.
The Reference File Manager menu item displays all of the reference file instances and is a central location to add remove and edit the reference file parameters.
Though you cannot edit the contents of a reference file in a project that is referencing it, the file itself can be opened and edited. If a referenced file is edited then saved, you will see the changes the next time the project referencing that file is opened or focused along with a message making you aware of the changes.
Reference file feature is available in modeling, drafting and layout.

Modeling

Non planar facetted surface objects are no longer treated as Wire objects. This behavior is consistent with classic versions of form•Z (pre v7). Note that objects with highly non planar surfaces can only be selected in shaded views by positioning the mouse on an edge of the object as the interior of these surfaces is not well defined.
Components use the new instance engine making them far more efficient. Files with components open much faster, use less memory and display faster. Support for nested components and component editing has been improved.

Tools

Reshape tool

The Reshape tool now has a non-dynamic option (like the extrusion tools). This makes quick work of reshaping multiple items a specific dimension.

Point Disturb

The classic form•Z Point disturb functions have been updated and re-introduced as (5) new tools: Linear Wave, Circular Wave Disturb Points Disturb Point Normals, and Spread.

Mass properties

The Mass properties tool has been updated to include “American Tons”.

Modeling Text

The Modeling Text tool is sensitive to the reference plane and the viewing direction (i.e. text placed on a plane that faces away from the viewer is now created on the other side of the plane, i.e. facing the viewer).

Transformation tools

The Transformation tools have all been made more efficient. Transforming and copying complex objects is now much more responsive. The classic tool options for the transformations have been updated and re-introduced.

Rectangular Array

The new Rectangular Array tool quickly makes copies of objects in all three Cartesian directions with control over the offset between copies or the space between them.
The new Radial Array tool quickly makes copies of objects around a pole (axis) with control over the spacing and an optional vertical offset.

Object Symmetry tool

The new Object Symmetry tool adds symmetry control to objects. Once an object has the symmetric control, subsequent operations to the object maintain symmetry. The Object symmetry is sensitive to the type of object with special consideration for NURBs curves, NURB surfaces and Sub-D objects.

When the Object Symmetry tool is selected, a default symmetry plane is positioned with the standard form•Z plane controller and the object is made symmetric about that plane. For objects without special consideration, the object is effectively sliced at the plane of symmetry, a copy of this is reflected about the plane and then stitched back to a solid (or surface depending on the original object and the relationship of the symmetry plane.
The object with special consideration are handled specific to their parameterization to achieve a desired symmetric result (i.e. the underlying controls are made symmetric and the object is re-constructed from the new controls).

The symmetry plane can be positioned dynamically using the graphic controls. A set of utility buttons in the Tool options palette allow for quick positioning to common planes (Cartesian planes for example). The “Flip” button swaps which side of the plane is maintained.

When an object has symmetric control, the symmetry plane is shown in dashed lines when the object is highlighted. Symmetry is maintained when the object is later edited. For example:
  • Editing the cage of a symmetric Sub-D object, will update the cage point about the plane of symmetry and update the surface.
  • Applying a Sub-D tool to a Sub-D object, will update the cage using the symmetric plane and update the surface.
  • Editing a control point of a symmetric NURBs object, will update the reflected control point.
(Note that editing operations that cross objects plane of symmetry the may generate unexpected results.)

Symmetric Solid Example

A wedge shape object is made symmetric; the symmetry Plane is edited to create the desired form; The offset segment and reshape tools are applied to one side of the object and the opposite side is updated.


Symmetric NURBs Example

A NURBSs object is made symmetric at one edge; Edit Controls is enabled and the controls are moved on one side of the plane and the symmetric controls are updated symmetrically.

Symmetric Sub-D example

A Sub-D object is made symmetric; Edit Controls is enabled and the controls are moved on one side of the plane and the symmetric controls are updated. The Grow face tool is applied to one side of the object and the symmetry is updated.

If the symmetry tool is applied to an object that is already symmetric, a new plane of symmetry is established.
The Scale to Size tool provides a way to scale an object to a specific size in any of the three Cartesian axis. This is similar to the classic form•Z Absolute scale feature.

File formats

  • SketchUp SKP updated and now includes export.
  • PSD (new direct translator).
  • Jpeg/Tiff/Png have been updated.
  • STEP has been updated.
  • OpenNurbs import has been updated to v6.
  • DWG/DXF/DWF have been updated.
  • Quicktime Image formats are deprecated by Apple and have been removed.

form•Z Draft Layout

form•Z Draft Layout is a new app that combines the features of the classic form•Z Drafting environment (v6 and earlier) and the layout environment of form•Z 7/8. This includes the separate draft and layout spaces from v6 and the sheet management and dimension styles from v 7/8.

Draft Space is a real world scale 2D environment. This environment is ideal when you need to work on 2D data at its actual size. Layout Space is a paper scale 2D environment. It is designed for multi sheet layouts of drawings. form•Z Draft Layout and it can open classic form•Z Drafting files directly!

The updated FML file format maintains a draft and layout space for each project. The FML format is now much more efficient than previous versions (i.e. files are smaller).

When starting a new Draft Layout project, you can choose to start in Draft or Layout space. The Layout mode item in the Display menu indicates if you are viewing the layout Space. Use this to switch between spaces.

Layout Space now has a number of features found in the classic form•Z color drafting environment: Color Palette, Draft Pane creation and selection tools.

Scripting

FSL (form•Z script language) has been replaced by Python scripting for formZ. The python script interface is much simpler to use than FSL and opens up the vast library of readily available python libraries for various functions and interfaces. form•Z uses Python 2.7. This version is installed by default on Mac OS 10.11-10.14. Mac OS 10.15 (and later) aa well as all windows users, need to install python form here:https://www.python.org/download/releases/2.7/

For more information CLICK HERE.