The animation process

There are four ways to convert a static entity into an animated entity. An animated entity is an entity that can change its position or shape over time. Once an entity is animated, it is listed in the Animation Editor palette that lists all of the animated entities in the project.

 

Using the Keyframe tool

(Cic_3734.ENU.png)

The Keyframe tool is discussed in more detail in the Animation Tools section. When this tool is used on a static entity, it makes the entity animated and creates default tracks and default keys for the current state of the entity at the current time. A Bezier controller is created for each track with a single key representing the current state. At this point, as there is only a single keyframe, the entity will not actually change when the current time is changed in the Animation Time Line palette. The next step is to add additional keyframes to define the state of the entity at additional key points in time. Additional key frames can be added using auto keyframing or manual keyframing methods.

 

a
keyframe_ex1.png
b
c
d
Auto key framing: (a) A cube is animated using the
Keyframe tool (current time = 0). (b) Current time is set to 5
and the cube is movedto the desired location.
(c) Current time is set to 2.5 and the cube is again moved
with the Move tool. (d) The cube is moved
to a new location for time of 2.5 seconds.

With auto keyframing, form•Z automatically adds and updates keys when required as an entity is edited. That is, as changes are made using form•Z tools and dialogs, these changes are automatically reflected in the animation of the entity. Automatic key framing is controlled by the Auto Keyframe icon (auto_key5.png) in the Animation Time Line palette. Auto keyframing is on by default.

 

To add a key with the auto method, first set the current time to the desired time for the new key using the Animation Time Line palette. Next make the desired changes to the entity. As the changes are made, the necessary keys are added to the controllers to keep the animation on track with the changes. The process is repeated as many times as needed to produce the desired results.

 

When auto keyframing is disabled, manual keyframing can be used to add keys. To add a key with this method, first set the current time to the desired time for the key using the Animation Time Line palette. Next, perform the necessary operations to the entities or edit their parameters to establish the desired state of the entity for the time. At this point the entity is said to be off track. That is, it is not in a state that is represented by the animation tracks. Once the desired state is achieved, click on the object using the Keyframe tool. This establishes a new keyframe at the desired time. If a keyframe already exists at the current time, its values are changed to the new values. The entity is no longer off track. The process is repeated as many times as needed to produce the desired results.

 

a
keyframe_ex2_1.png
b
c
d
e
keyframe_ex2_2.png
f
g
Manual key framing:
(a) A cube is animated with the Keyframe tool (current time = 0).
(b) Current time is set to 5 and the cube is moved to the desired location.
(c) The cube is clicked with the Keyframe tool to add a new key frame.
(d) Current time is set to 2.5 and the cube is moved again.
(e) The cube is clicked with the Keyframe tool to add a key frame.
(f) Cube is moved to a new location.
(g) The cube is clicked with the Keyframe tool to update the key frame.
 

 

 

If an animated entity is off track and the current time is changed using the Animation Time Line palette, the Entity Off Track warning is issued as shown below. This offers the opportunity to retain the state of the off track entities.

 

entity_off_track.png
Entity Off Track alert dialog.

 

 

Keep Entities Off Track: Clicking on this button keeps the off track entities in their off track position and parameters. This allows for the current time to be changed without losing the changes to the entities. The entities can then be keyframed at the new time with the Keyframe tool.

 

Keyframe Changed Entities: Clicking on this button keyframes all of the off track entities at the current time. This is equivalent to selecting all of the off track objects with the Keyframe tool.

 

Cancel: If you click on this button leaves the current time unchanged.

 

Do Not Keep Changes: If you click on this button the changes made to the off track entities are discarded and the entity goes back to its position for the new time.

 

Using the Animate Along Path tool

(Cic_3734.ENU.png)

The second method is to use the Animate along Path tool, which is discussed in more detail in the Animation Tools section. This tool makes an object animated such that its position and rotation are controlled by a path defined by a form•Z object. The tool creates default path tracks and default keyframes. A Bezier controller is created for each track with a keyframe at the start and a keyframe at the end of the path. The entity is animated from the start to the end of the path. The path object is not changed by the operation, hence if the path is edited, the animated entity follows the updated path.

 

a
animate-along-path.png
b
c
d
Animate along Path tool: (a) The original cube and spline path.
(b) The cube is made animated by activating the Animate along Path tool and
clicking on the cube and the spline path. (c) The current time is changed to 5 seconds.
(d) The spline path is edited by using on screen controls.

 

 

Using the Animate Entities tool

(Cic_3734.ENU.png)

The third method is to use the Animate Entities tool, which uses a set of existing entities to create a single animated entity. To do this, prepick the objects you wish to animate, using the Pick tool, and then, with the Animate Entities tool active, click anywhere in the project window. Note that it only makes sense to pick objects that are copies of the same object. When dissimilar objects are picked, the first one will be the entity that will be animated. The others will only be used for their location and orientation.

 

Each of the selected entities represents a keyframe of the animation sequence. This tool provides similar functionality to the Animation From Keyframes menu command found in previous versions of form•Z.

 

a
animate_entities_ex1.png
b
c
Using the Animate Entities tool: (a) The original cube.
(b) The cube copied and positioned at desired locations.
(c) With the Pick tool, the cubes are preselected in the desired order and then, with the Animate Entities tool active, we click anywhere in the project window.

 

 

Animating through the Animation Editor palette

The final method is to drag the name of an object, light, or view from the Objects, Lights, Views, or Materials palette into the Animation Editor palette. This is done by placing the mouse on the name in the desired palette, clicking on the name and holding the mouse button down to drag it to the desired position in the Animation Editor palette. As with the first method, default tracks and controllers are created with single key values for the current state.

 

Animating parameters

a
animate_height.png
b
c
d
E

Animating the height of a cube with
auto keyframing: (a) The cube is
made animated by using the Keyframe
tool with current time = 0.
(b) Time is set to 5, cube is moved
to a new location, and its height is
changed using on screen controls(c)
Current time is set to 4 seconds. (d)
The height is changed using using
on screen controls (e) Current time
is set to 2.5 seconds.
 

In addition to animating an object's position, rotation, and scale, most entities’ parameters can be animated as well. A corresponding track is available for each parameter that can be animated. By default, when an entity is made animated, tracks are created for the primary parameters of entities. These are the parameters that are commonly animated and are found in nature. There are a variety of ways to control which parameter tracks are created, as discussed in later sections.

 

Parameter tracks are also added by default when a keyframe is added (using auto keyframing or with the Keyframe tool) and a parameter is changed. That is, if a parameter has a different value at the time the key is inserted than the adjacent keys, the parameter track is added and the necessary keys are created. If an object is already animated, parameter tracks can also be added manually by right clicking the name of the object in the Animation Editor palette and selecting Add Tracks... from the context menu.

 

Numeric control of animated information

Some dialogs contain parameters that are animatable, indicated by a small bullet to their right. This bullet is also a menu that pops up when pressing the mouse cursor on it. The bullet graphic representation changes to reflect the status of the parameter, as follows:

 

[i_red.tif] The parameter is animatable, but is currently not animated. If there is no graphic present, then the parameter is not animatable.

 

[i_key.tif] The parameter is animated and its current value represents a key value at the current time.

 

[i_arrow.tif] The parameter is animated and the current value does not represent a key value.

 

[i_lock.tif] The parameter is animated, but the track is currently locked so the parameter cannot be changed.

 

The bullet menu contains four items used to control the animation state of the parameter as follows:

 

Add Track: The track for this parameter is added and a key is added for the current value at the current time. This is only available if the parameter is not animated (the track does not exist).

 

Add Key: A key is added for the current value at the current time. This is only available if the parameter is animated and there is not already a key at the current time.

 

Remove Key: The current key associated with the value is deleted. This is only available if the parameter has a key at the current time.

 

Delete Track: The track corresponding to the parameter is removed and the parameter is no longer animated. This is only available if the parameter is animated and is not locked.

 

add_track_ex1.png
The Add Track popup menu from the Material Parameters palette.

 

Fine tuning, rendering, viewing, and exporting animations

The creation of a successful animation usually requires refinement of the animation parameters to achieve the desired results. Using the keyframing techniques described earlier allows for control of the critical values in the animation, however, it does not offer control over the transition between the key frames. This can be controlled using the Animation Editor palette. This palette offers complete control over the details of the track and controller parameters.

 

Rendering an animation

An animation is rendered by selecting Generate Animation... from the Display menu. Selecting this item invokes the Animation Generation dialog, where generation parameters can be set, including the type of rendering and the name of the file into which the animation will be stored. Clicking Generate Animation... starts the rendering process during which a progress bar dialog continuously displays the frame number that is currently rendered, the rendered image is displayed in the screen background and the rendered frames are entered in the Animation Time Line palette. After the process is completed the animation is saved in a file carrying the name entered in the Animation Generation dialog and the suffix “.fan”, which stands for “form•Z animation.” Note that this is a form•Z internal format that cannot be read by another application. To open the animation in another program it will need to be exported to another format.

 

Viewing an animation

An animation can be played by selecting the Play Animation... item in the Display menu, which first invokes the Animation Playback dialog for setting the playing parameters. When clicking on OK, the animation is run. The screen is cleared and only the animation window appears. If Loop was selected in the Animation Playback dialog, the animation plays continuously by looping back to its beginning, until it is interrupted by pressing esc or command+period (Macintosh) or ctrl+period (Windows).

 

An animation can also be viewed using the View File menu command. When the Open File dialog is invoked you can select the “.fan” file you wish to view.

 

Exporting an animation

To be able to take the animation to another application, it needs to be saved accordingly. From the File menu you select Export Animation.... This invokes an Open File dialog where the form•Z animation file to be exported is selected. A File Save dialog is then invoked for selection of the format and name of the file to be exported. Animations can be exported to formats including QuickTime™ Movie or AVI (Windows) or as a set of independent image files (such as TIFF or Targa).

 

After a QuickTime™ Movie (.mov) or AVI (.avi) file has been exported, it can also be played from within form•Z. This is done by selecting View File... from the File menu. When the Open File dialog is invoked you can select the animation file you wish to view.

 

The animation preferences

The animation features of form•Z can be turned on or off through an option in the Animation tab of the Preferences dialog, invoked by clicking on the Preferences... item in the Edit menu.

 

Enable Animation: When this option is on, the animation features in form•Z are active and usable. They are disabled otherwise.

 

anim_prefs.png
The Animation tab of the Preferences dialog.
spacer