Edit Menu

M_Edit
The Edit menu.
M_Edit
The Object Duplication Offset dialog.

This menu consists of seven groups of mostly standard commands.

 

The first group contains undo and redo commands which are affected by settings in the Preferences dialog, Project: Undo section. The undos are unlimited by default and may or may not be saved with projects. They are not by default. By default they are also reset every time a project is saved, but this is optional.

 

The second group contains the standard Cut, Copy, Paste, and Duplicate commands. If you select the latter while pressing the option key, the Object Duplication Offset dialog is invoked, where X, Y, and Z offset values can entered. The same dialog can be invoked directly with the Duplication Offset... command, found at the end of this group.

 

The third group contains commands for selecting and deselecting and for global deletions (clearing). Recall that form•Z objects can be active or ghosted and there are separate commands for dealing with each category.

 

The fourth group contains items that control the status of objects, after operations are applied to them. You can instruct the program to Ghost, Delete, or Keep the operand objects of an operation. Also in this group is Apply To All Operands, which applies when parts of objects are used in an operation. For example, a new extrusion is generated from the face of an object. By default, the object on which the face is excluded from the above options and it is kept as it is (it is neither ghosted nor deleted). However, if Apply To All Operands is on, the Ghost, Delete, or Keep options will apply to this object as well.

 

The next item in this group is Clear Ghosted Operands. There are two ways in which objects can be ghosted in form•Z. The first is as a result of an operation applied to them. The second is by using the Ghost tool and explicitly ghosting an object. This command will clear (delete) only the ghosted objects that resulted from operations.

 

Place Derivatives On Active Layer and Derivatives Use Current Material are new options in the Edit menu. These control what layers and materials are applied to objects that are derived from other objects (as with the Extrusion or Revolve tool, for example). When these options are enabled, the current material or layer is used (the default action in prior versions of form•Z). When not enabled, the layer of material of the source object is used.

 

The fifth group contains commands that relate to picking. When Click And Drag is checked, you can execute a move by simply clicking and dragging rather than using the Move tool.

 

When 2 Click Face/Outline Selection is checked, faces and outlines are picked with two clicks. When Selection Preview is checked, entities are highlighted when the mouse cursor is placed on them, indicating that they will be picked when the mouse is clicked.

 

The sixth group contains two commands: Unlock Groups and Unlock Components. When these are on the members (objects) of the groups or components and their parts (faces, segments, points, etc.) can be picked by a Pick tool or by any other tool that may post pick them to execute an operation. In such a case groups can still be post picked as groups by tools that expect a group. When these items are off, which is the default, groups or components can only be picked as groups or components.

 

 

 
M_Edit
Part of the Component Manager Palette.
M_Edit
The Component Changed Warning Dialog.

When making changes to a component, one of three options may apply: Update Component, Make New Component, or Ask, which is selected from the Component Manager palette. When Ask is on, every time you make a change to a component the Component Changed prompt is issued, offering the above options.

 

The seventh group contains commands relating to grouping and components. The Group and Ungroup items function the same as the Group and Ungroup tools, when used with the prepick selection method.

 

Once objects are grouped they can only be manipulated as a group and the individual objects cannot be accessed. The Edit Group/Component command provides for a way to edit the objects and the composition of a group or component. When selected, all of the objects in the model that are not a part of the group become temporarily ghosted. The Objects palette only shows the objects that are in the group. The bounding box of the group is shown with a dashed line. Objects in the group can now be selected, modified and deleted. Any new objects that are drawn become a part of the group. Selecting the Edit Group Complete command terminates the editing of the group. The rest of the model is revealed (unghosted) and the Objects palette again displays the entire model. Recall that grouping is hierarchical. That is, when two groups are themselves grouped, the hierarchy is retained forming nested groups (or groups within groups). Group editing functions on nested groups. That is, while editing a group, Edit Group/Component can be selected again on a nested group to edit its contents. When editing nested groups, Edit Group Complete must be selected to terminate editing for each level of nesting.

 

When the group that is edited is a component group, all of the instances of the component are updated when the editing is completed. The instances remain visible for reference and they are shown with a dashed bounding box. Additional on screen controls are displayed that represent the origin and coordinate system of the content definition.

 

Note that the project cannot be saved or closed while group editing is in progress. During group editing, the Undo command cannot undo beyond the point where group editing began. Once group editing is complete, a single undo will undo all of the editing performed while editing the group.

 

Make Individual Component is the last item in the seventh group. There are times when it is desirable to edit placed component without changing all of the instances placed in the project. Make Individual Component makes the selected component unique by creating a new component definition in the project for the selected instances. That is, the definition of the component is duplicated and the selected instances are adjusted to use the new component definition.

 

The eighth group contains the Isolate Objects and Reveal Objects commands.

 

When working on a complex model there are times when it is desirable to isolate a small set of objects for working on a detail of the model. The Isolate Object menu item isolates the currently selected objects by temporarily ghosting the remaining objects in the scene. This can be applied repeatedly to further reduce the number of visible objects. The Reveal Object menu item unghosts all of the objects that were previously ghosted by the Isolate command.

 

Note that the project cannot be saved or closed while objects are isolated. Also note that although Isolate can be used multiple times to reduce the number of workable objects, Reveal only needs to be used once to display all of the objects.

 

The ninth group contains the Key Shortcuts… and Preferences… commands. Each of these is discussed in a separate section.

spacer