Preferences: System

When Preferences... is selected from the Edit menu the Preferences dialog is invoked. This dialog is structured hierarchically and displays a list of categories on its left side. Clicking on an item displays the options that affect that item.

 

System: General

This category specifies which preference file to use and what action to perform at start-up.

 

Preferences File: This group determines what preference settings will be applied when form•Z is launched. When the selected option is changed, you have the opportunity to change preferences immediately or at the next launch.

Use Custom Preference File: The parameters stored in the file whose name appears in the field of this option will be applied.

 

At Quit: when quitting form•Z, changes you have made to preferences since launching the application will either be saved, not saved (preferences remain unchanged), or a prompt will appear asking if changes to the preferences should or should not be kept. The commands are: Save Preference File, Do Not Save Preference File, and Ask to Save Preference File.

 

Reset to Defaults Now...: this button restores the Preferences to the original default state that appears the very first time you launch form•Z.

 

Startup Action: Determines what command is performed when form•Z is launched. The options are: New Project (creates a new project), Open (opens an existing file that the user chooses) and None (does nothing).

prefs_general.png
prefs_general.png
The Preferences dialog with the System: General options displayed.

 

 

System: Language

This category offers the ability to switch between different languages. Note that the language defaults are determined by the operating system settings. On OS X they are found in the International System Preferences. On Windows they are in the Regional and Language Options control panel.

Language: This menu determines what language is used through out the form•Z interface. It contains a list of all languages installed. The default language is determined from the operating system’s language. If the default system language was not installed by the form•Z Installer, English is used as the default language. Note that changes to this setting take effect the next time form•Z is launched.

 

Field Separator: This character is used to delimit lists of numbers.

 

OS Default: With this option the default is determined by the settings on your computer. The default is the comma (,) for localization settings where a period (.) is used as the decimal separator. The default is a semi colon (;) for settings where a comma (,) is used as the decimal separator.

 

Custom: With this option the character entered in its text field is used as the field separator.

 

Default Units: This group determines the default work units. There are three options: OS Default (default is determined by the operating system), English and Metric.

D_Pref_Sys_Language
D_Pref_Sys_Language
The Preferences dialog with the System: Language options displayed.

 

 

System: Interface

The Interface options are organized into two tabs: Dialogs and Palettes. There are some options that appear directly in the Interface tab, rather than the sub-tabs.

 

Show Tips: when checked this option will display pop-up tool tips when the cursor is moved over a tool icon. Delay Seconds is the length of time that the cursor needs to be left over the tool icon before the tool tip pop-up appears.

 

Colors Used in Lists: These options specify the colors used for the background of lists in palettes and dialogs. These colors are intended to make lists easier to read. They are: Title Row Color, Even Row Color, and Odd Row Color. Each is associated with a color box whose color can be changed.

 

Icon Display: there are two slider controls here for changing the appearance of the icons throughout the interface.

 

Saturation: moving this slider will alter the how vivid the colors of the icons are. Moving it as far left as possible will make the icons appear in grayscale mode only. Moving it between far left and far right will create a mix of the full color icons and gray icons, muting the colors by the amount selected.

 

Tint: This color box and slider can be used to assign a custom color that will be mixed with the icons, the Intensity slider controls the strength of this mixture.

 

The sample icons directly below the the display sliders preview the changes made to the sliders. The form•Z application must be restarted before changes to the icons will appear.

 

D_Pref_Sys_Language
D_Pref_Sys_Language
Preferences: System: Interface Options: Interface tab.

 

Interface: Dialogs

Fonts: Font Name controls which font and Font Size the text size used in the dialogs. The Reset To Defaults button resets the font and size to the system defaults. Note that the changes in the font settings are not visible until the next dialog is opened. The default font settings vary depending on the language and operating system.

 

Order Of Buttons: These options determine the order of the standard OK, Cancel, and Reset buttons at the bottom of the dialog. Reset, Cancel, OK is the default for OS X and OK, Cancel, Reset is the default for Windows.

 

Use Sheet Dialogs For Alerts: Applying to OS X only, when on, alert messages are displayed in sheets that slide out from the top of the active window rather than in an independent alert window.

 

 

D_Pref_Sys_interf_Ds
D_Pref_Sys_interf_Ds
Preferences: System: Interface options: Dialogs tab.

 

 

Interface: Palettes

Fonts, Font Name, Font Size, Reset To Defaults: As for the Dialogs tab.

 

List Palettes: If checked, the tool names are shown below each icon on the main tool palette. Uncheck this to turn off display of the tool names. This will make the tool palette smaller. Note that this option is only available on displays with a height greater than 800 pixels. On displays less than 800 pixels high, this option is always off (no tool names).

 

Clicking in an Empty Space Creates a New Entry: this item when checked allows the creation of new items in palettes by simply clicking in a blank area of the list. This method of creating new items will be in addition to the green Add (Add) icon at the top of each list palette.

 

form•Z classic layout: this alters the appearance of the list palettes to be as those of the previous versions of form•Z. In this layout, the icon columns will be displayed at the left side of each palette, instead of on the right.

 

Keep Lists Tightly Spaced: this setting reduces the space between lists.

 

Show Vertical Separators: this setting draws thin vertical lines between the columns.

 

Animate Palette Transitions: this setting causes the collapsing and expanding of palettes to appear to either gradually expand and contract, or do so instantly with no gradual transition.

 

Pop-Up Tool Palettes On Hover: this setting causes the pop-out tool rows to pop-up automatically when the cursor is left over a tool icon that starts a pop-out tool row. If this setting is not checked, the mouse must be clicked and then released on the first tool icon before the tool row will pop up. This is closer to the way this worked in previous versions of form•Z.

 

prefs_interface_palettes_tab.png
prefs_interface_palettes_tab.png
Preferences: System: Interface options: Palettes tab.

 

 

Scratch Disk

These options provide control over the location of the temporary (or scratch) files of form•Z. These files contain information such as the undo and redo records and are hidden so that they are not accidentally deleted while the program is running. The default scratch location is the system default temporary directory, but you are allowed to specify a different location.

 

Use System Temporary Folder: With this on, the scratch files are stored in the systems temporary directory, the location of which varies, depending on the operating system. Consult your operating system’s documentation for the exact location.

 

Custom: With this option a user defined location for the scratch files can be specified. When you click on the Choose Location... button, the Standard Folder Selection dialog appears, where you select the folder where the scratch files will be saved, and click on the Choose button. This dialog also contains a New Folder button, which can be used to set up a new folder. A scratch disk on RAM can be selected through this option. Note, however, that such a scratch disk should first be set at the operating system level before running form•Z.

 

Location: This information field shows the full path of the location where the scratch files will be saved. Because the scratch files are already open when the application is running, their location will change only when form•Z is launched again.

 

Current Location: This information field shows the current location of the scratch disk. This is useful since the new setting entered in the Location field does not take effect until form•Z is relaunched.

 

D_Pref_Sys_ScrDisk
D_Pref_Sys_ScrDisk
The Preferences dialog with the System: Scratch Disk options displayed.

 

 

Recent Files

These options affect the Open Recent item of the File menu.

 

Maximum Number Of Files: This text field determines the maximum number of files that are remembered and shown in the Open Recent list. When this maximum is reached, the oldest file is “forgotten” so that a newer file can be remembered. "Old" and "new" refers to when the file was last opened or saved within form•Z, not when the file was created. The default is 10, the minimum is 1, and the maximum is 100.

 

Show Full Path In Menus: With this option, which is the default, the full path for accessing the file is shown in the menu. The full path is the complete hierarchy of the file system directory necessary to access the file. When this option is off, only the file name is shown. This option is useful for distinguishing files with the same name but different locations. If the path is too long to fit in the menu, the middle of the path is truncated.

 

Sort Menu By Name: When this option is on, the Open Recent list is sorted in alphabetic order by the file name. When off, the list is sorted by order of use, with the most recent file at the top of the menu and the “oldest” at the bottom.

 

Clear Open Recent Menu, Clear Import Recent Menu, Clear View Recent Menu: Clicking on one of these buttons clears the respective Open Recent files list. These buttons are dimmed and inactive if the respective files list is empty.

 

D_Pref_Sys_RecFiles
D_Pref_Sys_RecFiles
The Preferences dialog with the System: Recent Files options displayed.

 

OpenGL

This section of the Preferences dialog contains information about the OpenGL Version and Vendor.

 

 
OpenGL Preferences
The Preferences dialog with the OpenGL information displayed.

 

Updates

The updates manager is designed to keep users informed of new updates and versions of form•Z. It checks with the AutoDesSys server to see if there are any patches available for form•Z. If yes, it will download the patch, the Patcher application, and the corrections log file. It will then update form•Z and create a backup copy of the current version. The options in this group specify how frequently checks for updates will be made.

 

Check For Updates At Startup: With this option, form•Z checks for updates at the time it is launched.

 

Check For Updates: This pop up menu is only available when Check For Updates At Startup is on and contains three items: Daily, Weekly, and Monthly. Selection of one of them determines how frequently form•Z will check for updates when it starts up.

 

You can check for updates manually at any time by choosing "Check for Update" from the Help menu.

 

D_Pref_Sys_Updates
The Preferences dialog with the System: Updates options displayed.
spacer