Layout

Print_OS_X_small.png
The Layout dialog.

 

Layout is an environment within form•Z that is used for the preparation of drafted documents of projects based on sheets. In layout mode, the graphics environment is 2D and the working surface is the sheet. The drawing is created by placing views of a 3D model at specific scales and specific locations on the sheet. These graphic representations are linked to the original model so that, as the model evolves, the layout can be automatically updated.

 

Additional graphic elements can be added in the layout including line work, shapes, dimensions, hatches and images. The graphic images of the model can be edited to make any required 2D changes to the drawing. Form•Z layout projects are stored in a project file with an .fml extension.

 

Selecting the New Layout Project item from the File menu creates a layout project. This invokes the New Layout dialog that is used to define the parameters of a layout. The Name of the layout project is the name that will be used when the project is saved. The Units are defaulted to Inches or Centimeters depending on your computer's settings.

 

Layouts are based on a specific paper size. All sheets in the layout use the same paper size. The Standard Paper Size menu lists a number of commonly used paper sizes. The Landscape option orients the paper horizontally and is on by default. The Custom Paper Size options are available so that you may use a sheet size that does not appear in the Standard Paper Size menu.

 

The Margin settings define the border around the physical edge of the paper in which nothing is printed. The margin settings can be used to limit the printing for aesthetic reasons, but also it is important to note that most printers cannot print to the edge of the paper. So you should select a margin that reflects the printer's characteristics.

 

The Border option causes a border line of the desired Weight to be drawn around each sheet, just inside the margin.

 

When the options are complete, the new project is created with a single sheet as a starting point. The graphic window shows a display of the sheet. The form•Z workspace is transformed into an environment that offers the tools and palettes that are useful for layout tasks. A number of menu items and standard tools will appear dimmed, as they are not available in the layout workspace.

 

The Layout options can be changed, after the project is created, in the Project Settings dialog, invoked from the File menu. The Layout tab contains all of the same options as the New Layout dialog. Note that changing the paper size after a drawing has been created can cause the drawing to be disturbed if the paper size changes cause elements in the drawing to collide or be arranged on different pages.

 

 

missing image file
A Layout with two sheets.

 

Layout Tools

The Layout tool palette contains a subset of the form•Z tools. These are the tools that are appropriate for creating documents in the layout environment. Note that some tools have options that are not appropriate for the layout environment. For example, the Move tool and all the transformation tools do not have the options for parallel or perpendicular to reference plane motions, as in layout the working plane is always the sheet.

 

There are four tools that are unique to the layout workspace. They are in the layout tool suite, in the third row of tools, in the layout workspace.